#1 

Q-Tec
Призрак Live-Co
Имя: Дмитрий
Откуда: Estonia - Ahtme
Зарегистрирован: 2006-02-24
Сообщений: 3850
На форуме: 1835 час.
Репутация: 282 (100%) ±
Инфо  Вебсайт  Написать

https://imgs.su/upload/131/339269059.png
Чёт я потерялся в формулах экселя...
Смотрите, может кто знает как такое сделать... Есть таблица, в который ведётся так сказать финансы..

Поле B = Суммы выплат
Поле C = Отметка о выплате в виде знака +

Как составить формулу, что если в поле B стоит знак + то вычесть из поля B11 (Общая сумма) ту сумму, напротив который стоит +


Или так нельзя?

Отредактированно Q-Tec (2017-11-01 21:22:29)

Неактивен

#2 

Q-Tec
Призрак Live-Co
Имя: Дмитрий
Откуда: Estonia - Ahtme
Зарегистрирован: 2006-02-24
Сообщений: 3850
На форуме: 1835 час.
Репутация: 282 (100%) ±
Инфо  Вебсайт  Написать

Хотя я думаю, что я снова туплю, и в одной ячейке такое не сделать.
Разделил на 2 ячейки

Первая =СУММЕСЛИ(C2:C10;"+";B2:B10)
Вторая = =B11-C11

Если кому понадобиться (остаётся не оплаченная сумма, которые без знака "+")

Неактивен

#3 

admiral
Status is loading... 99,9%
Имя: Alexandr
Откуда: берутся NaNы?
Зарегистрирован: 2007-02-04
Сообщений: 6595
На форуме: 1710 час.
Репутация: 1122 (100%) ±
Инфо  Вебсайт  Написать

Excel умеет это и в одной ячейки, просто не все умеют его готовить)
=СУММ(B2:B10)-СУММЕСЛИМН(B2:B10;C2:C10;"+")


Скорая помощь - всегда рядом!
99% ошибок сидит в полуметре от монитора.

Неактивен

[ Generated in 0.005 seconds, 10 queries]